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The Basics 

Internet Explorer 

Internet Explorer (IE) is a web browser that runs web-based applications like Oracle Financials.   
It has its own tools and features, some that that also can help with other applications like 

Odyssey, Outlook, Kronos, Etc.   Right click any blue area to the right or above the tabbed 

screen.  Check or un-check the listed options.  (Recommend Favorites, Command Bar and 

Status Bar) 

Oracle works best with IE version 8 you can click Help (?) and select about Internet Explorer to 

see the version on your machine.  If your version is higher you can make it work better by 
clicking the Compatibility View Button next to the refresh button.  You may need to add the 

button first. 

 

Trusted Sites:  Internal applications should 

be trusted within IE.   
1. Tools (click)  

2. Internet Options (Click) 

3. Security (Tab) (Click) 

4. Trusted Sites Green Check (Click) 

5. Trusted sites Diaolog box 

a. Remove the check box 
b. Enter websites and c. click Add 

https://*.dallascounty.org 

http://*.dallascounty.org  

6. Close when finished. 

  

IE Export Setting:  Stay at the security tab 
choose the Custom Level Button.  Scroll to this 

setting and click enable.   

 

Sometimes 

computer 
changes will require these settings to be redone.

Status Bar Shows 
if a website is 

trusted or not. 

Command 
Bar Help 
and Tools 

a 

c b 

Compatibility button 

https://*.dallascounty.org/
http://*.dallascounty.org/
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Logging On to Oracle Applications 
 
1. Locate the Dallas County Folder. It will be on the G drive.  

2. Choose the Dallas County ESS shortcut to go directly to Oracle.   

3. Oracle Kronos for Windows will take to a menu first.  But from there you can choose Oracle 

Applications. 

 
 

3. 
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After choosing an entry point for Oracle Applications, the E-Business Suite Login window will 

appear:  

 

 
 

You need an Oracle Applications Username and Password to log on to Oracle Applications.   

 

TIP:  When this screen is displayed you can save the URL link to your favorites as part of the 
drop down list or vertical tool bar.  Use the Favorites menu option or the Favorites star icon to 

save the URL.  You can rename and remove favorites using the right mouse click menu.  

 
 

 
To log on to Oracle Applications: 

1. Enter your User Name.  (Usually First Initial and Last Name or your Employee Number).  [Tab]  

2. Enter your Password. 

(Notice your password does not appear on the screen.  This prevents others from seeing it.  

Keep your password confidential to prevent unauthorized access to Oracle). 

3. Click the Login button or press the [Enter] key.  
4. Login Assistance?  This feature lets you reset your password if you are locked out instead 

of calling the Service Desk but, first you must set up your Dallas County Email address in 

DC Employee Self Service (ESS).   

 

Navigate to ESS responsibility and the View, Update Personal Information function and 
update the Organization Email Address.   

 

1   
 

2 4 
5 

Favorites vertical tool bar  (star+ adds)  
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Using the Oracle Home Page 
 

When you log in to Oracle Applications your E-Business Suite Home page is displayed.  This is 

the web based portion of Oracle.   You will notice that as you navigate to the applications you 

may see a different technology.   Oracle is in the process of migrating completely to this web 
based format and if your areas of interest are Purchasing, AP and HR/Payroll you may not use 

the forms versions.       

Changing Your Password 

A suggestion is to change your Oracle password when your network and Outlook passwords 

change to keep them the same.   
 

1. Click on Preferences 

2. Enter the required information.  Note:  Use the [Tab] key or the mouse to navigate 

between fields.  Do not press [Enter]  

3. Click the Apply button.  Your new password takes effect immediately. 

 

1 

2 
 

 

3 
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Choosing a Responsibility 

Look at the pane labeled Main Menu.  Each high level folder represents a responsibility.  A 

responsibility is the way that Oracle allows a person to accomplish a specific job.  The name of 

the responsibility gives an indication of the following: 

 The application in which the job is performed:  Accounts Payable (AP), General Ledger (GL) 
or Purchasing (PO). 

 The position of the job being performed (Inquiry Only: Inquiry, Supervisor: Super, S1, S2, 
Clerical: C1, C2).   

 

You can have multiple responsibilities but only one can be active at a time in a single Oracle 

session.  When you click on the responsibility name or the + sign, menu options appear and 

you can drill down till you reach functions.  Click on a function and it will take you to an 

application window. 
 

Another option is to click a Favorite.   Favorites is drop down list that you manage to help you 

quickly get to a function.  The Favorites options are discussed in more detail shortly. 

 

 

 
 

 

 

 

 
 

 

 

 

 

 
 

 

 

 

 
 

 

 

 

 

 
 

 

 

 

 
 

The Worklist pane will display Oracle notifications.  An example of this is when you have your 

password automatically reset or if you are in the approval hierarchy within purchasing.    

Function 

Menu 

Responsibility 

Favorites 

Functions 
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The first time you invoke a forms based 

function Oracle opens the “Oracle 

Application R12 – Windows Internet Explorer 
window.   

  

This additional window provides some behind 

the scenes support for the forms based 

technology.  Do not close unless you are 

finished using oracle.    
 

TIP:  Oracle may give you a dialog box asking 

for you to grant permission to run a program 

check the do not show me this again box and 

select yes to prevent message from appearing 
again. 

 

Oracle will open a third window that will be related to the Java coffee cup icon on your 

windows tool bar.  This new window can contain navigation, information and data entry 

screens.  So at any given time you might have three active windows associated with oracle open 

at the same time. 
 

There is a fair amount of duplication between web and forms navigation.  At some point the 

Oracle Forms based technology will be removed and Oracle will be completely web based. 
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Setup & Using Favorites  

Oracle provides Favorites on your home page that allows you to navigate to specific functions 
quickly instead of having to hunt or drill down to them.   Favorites can cross applications and 

responsibilities so organizing them can be key.  
 

To add or remove options from the Favorites list, select Favorites and then Manage 

Favorites.    
 

 
 

If you are on a functional web page like View Pay Slip under DC Employee Self Service you may 

see a slightly different drop down when 

you select favorites. 

 

The new item is a short cut to allow you 
to add the current screen directly to 

your favorites. 

 

A screen will be provided to allow you to 

give the favorite a nick name. Click the 
Apply button to save. 
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The Manage Favorites option will be how you add Forms based functions and make changes to 

the existing list. 

 
 
To add to Favorites: 

 Search and Select do one of the following. 
o Responsibility -  Select a responsibility click Go and all the functions for that 

responsibility will be displayed in the Select Function Prompt area 

o Type a key word like “run”, “pay” or “invoice” and click Go and all the function that 

include that word in the menu prompt will be returned in the Select Function 

Prompt area. 

 Click the select check box for each of the functions you want on your favorites and click 
the Add button. 

Search 

Criteria 

Current 
Favorites 



Dallas County, Auditor’s Office 4/11/2018 

 11 

In this example there are Run functions under multiple responsibilities.  Choose a couple and 

click the Add button.  Notice how these functions move to the next section of the form. 

 
 Click the Apply button.  You will be back at the 

home page.   

Notice that your favorites list has changed. 

 

Running reports is a very popular function in 
Oracle but how do you know which responsibility 

you are going to when you have more than one? 

 

You can give yourself a tip by re-naming the 

favorite.  Return to Manage Favorites. 

 
Notice that I have changed 

the name under the Favorite 

column to reflect the module.  

Click Apply button to save. 

 
You can Select with a check 

box one or more functions 

and click Remove to remove 

a single favorite.  

 

You can use the Up and 
Down arrow keys to change 

placement on the list. 

 

To save and review your 

changes click the Apply 
button. 

 

The Add URL button 

will allow you to 

enter a web address 

that is outside of 
Oracle. MAKE sure 

that you click the 

Open new window 

check box on the far 

right.  If you don’t do 
this your Oracle web page will be replaced.  You can use the Oracle <- back button to return.

2. Remove 
function 

1. Check for 

Removal 
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Using Oracle Forms Navigator 
 
When you see this screen you have entered the Oracle Forms powered by JAVA this platform 

has its own navigation and most prefer to continue to use if they are working mostly in the 

forms-based application.   The Navigator uses collapsable menus but you will see the same 

functions names on the web side.  One drawback is you can only see functions for one 

responsibility can be displayed at a time.       
 

TIP:  Do not close out the Navigator window while in Oracle unless you are trying to quit. 

TIP:  The Top Ten List is like your favorites from the web page.  You can have up to 10 favorite 

functions on your Top 10 List for each responsibility.  

Tip:  You can highlight a title and use the action buttons or double click to expand or collapse. 

Tip:  Highlight a function to update Top Ten List or OPEN (Click Open button) 

 
               
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Use 

mouse 

Double 

click 

button 

 

Look for these information areas. 

1. Provides the name of the Oracle form and current responsibility 

2. Displays the name of the item currently selected 

3. Displays a description of that item  

4. This bar tells you the name of the current database.  If you are working in a test 

environment it should also tell you when the database was copied from production. 

 
 

1 

2 

Expand 
Branch 

Collapse 
All 

Expand 
All 

Collapse 

Expand  

3 

Add to Top Ten 

4 

Remove from Top Ten 
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Using Menus, Toolbars & Icons w/in Forms 
 

 
 

Within Oracle Applications, there is usually more than one way to accomplish a task.  The 

Toolbar, Short Cut keys, and Hot keys are a few examples.  See Help>Keyboard Help for a list 

of Short Cut keys.    

 
Most forms have four common parts: 

 

Oracle Menu Pull down actions and sub forms   Click here to see full list of menu 

definitions.  Not all features will be active depending on the form’s intended 

function.   

Icon Buttons Display short cut functions in a single button.   
Message Line Displays hints, warnings, or error information. 

Status Line Displays status information about the current window or field, such as query-

mode and record-count information. 

   

Pop-up Menus 

A right-mouse pop-up menu is available on all text items. It replicates a subset of functionality 
contained on the main pull-down menu, including up to 10 product-specific entries which 

would also be on the Tools, Actions or Reports menus. 

The pop-up menu should only appear if the user does a right-mouse click in the field that 

already has focus; right-mouse clicking on the noncurrent field should do nothing. 

3
2

Oracle Menu 

Icon Toolbar 

Oracle Message/Status line 



Dallas County, Auditor’s Office 4/11/2018 

 14 

The Forms Toolbar 

 

The toolbar icons and the actions they perform are as follows: 

1. The New icon opens a new record. 
2. The Find... icon invokes the Find window. 
3. The Show Navigator icon invokes the Navigator window. 
4. The Save icon saves your data. 
5. The Next Step icon advances you to the next step of a process (see Launch Business Processes). 
6. The Switch Responsibilities icon invokes the list of your responsibilities for you to choose another. 
7. The Print... icon prints the current screen. In some cases it may print a report associated with the 
current data. 
8. The Close Form icons closes all windows of the current form. 
9. The Cut icon cuts the current selection to the clipboard. 
10. The Copy icon copies the current selection to the clipboard. 
11. The Paste icon pastes from the clipboard into the current field. 
12. The Clear Record icon erases the current record from the form. 
13. The Delete icon deletes the current record from the database. 
14. The Edit Field... icon displays the Editor window for the current field. 
15. The Zoom icon invokes customer-defined drill-down behavior. 
16. The Translations... icon invokes the Translations window (see Creating Translations for a Record). 
17. The Attachments icon invokes the Attachments window. If attachments already exist, the icon 
appears as a paperclip holding paper (see Attachments). 
18. The Folder Tools icon invokes the Folder Tools palette window (see Customizing the Presentation 
of Data). 
19. The Window Help icon invokes online help for the current window. 

 

 

Using Wildcard Values  
 

Wildcards are symbols that represent one or more characters where the values are not known, often used 

in search related functions.  Different technologies use different symbols to represent wildcards, here we 

will discuss Oracle’s wildcards.   

 Percent (%) represents any number of unknown characters 

 Underline (_) represents a single character wildcard, in your search criterion. 
 

You could use wildcards in combination.   
A% would return all values that start with A, from A to AZ TURNER FALLS CAPITA 

%A would return all values that end with A, from to A to AZ TURNER FALLS CAPITA 

A%FALLS%A  would return AZ TURNER FALLS CAPITA and ANDREW FALLS PENYA 

___A%  would return all values where the 4 position had an A, 123A Rest Inc or A DAYNE 

MARGUGLIO 

 
Typically usage of wildcards is uniform… so once you understand wildcard techniques you can 

apply them where wildcards are supported. 

http://p615pd1a.dallascounty.org:8001/pls/FIN11I/fndgfm/fnd_help.get/US/FND/@ug_launch#ug_launch
http://p615pd1a.dallascounty.org:8001/pls/FIN11I/fndgfm/fnd_help.get/US/FND/@ug_trans#ug_trans
http://p615pd1a.dallascounty.org:8001/pls/FIN11I/fndgfm/fnd_help.get/US/FND/@ug_atta#ug_atta
http://p615pd1a.dallascounty.org:8001/pls/FIN11I/fndgfm/fnd_help.get/US/FND/@ug_fold#ug_fold
http://p615pd1a.dallascounty.org:8001/pls/FIN11I/fndgfm/fnd_help.get/US/FND/@ug_fold#ug_fold
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Field and Button Behavior 
 

Fields may appear the same until you navigate to them, then you may receive hints of 

underlying validation functions.   

 
 

 

Buttons:   Buttons can be clicked with a mouse, Pressing [Alt] + underlined letter or they 

can be invoked using the Enter Key if they are the default button usually noted by a darker 

outline.   To clear the Supplier search screen using [Alt] + c.   

  
List Of Values (LOV):  When you navigate to a text box and icon symbol (…) appears to 

the right you have entered a field using a LOV.   A LOV will allow you to search for a value but 

to pass validation a distinct item from the underlying list must be chosen or the field must 

remain blank.   Note: For dates the LOV will be a calendar.  
 

Key in a full or partial value (wildcards are supported and the rightmost wildcard is provided 

automatically). And press the (TAB) button on your keyboard or click the LOV icon.      

 

You can use the (ENTER) button instead of the (TAB) button but it will invoke default button 
on the search/entry screen once the LOV validation is passed.  In this example it would 

attempt to Find the Requestor.    

 

You can also click the LOV Icon without entering a 

value and the dialog box will look like this. 

 
If your entry returns multiple values the LOV 

dialog box will be return with values  where you 

can choose your selection by highlighting it click 

(OK) or press (Enter) or refine your search and 

Click [Find]. 
 

LOV example 

Default Button 

Pick List 

Text Field 
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  Tips: 

 To avoid excessive network traffic and reduced performance, try to enter criteria other than just '%' 

when searching for names or control items such as invoice numbers, etc.    

 If you start with criteria on the LOV text box you must “refine” search criteria not change.  If you 

need to change your criteria cancel the dialog box and change the initial search value. 

 If a search form is behaving oddly use the [Clear] button to make sure all values are reset and blanks 

are removed. 

 

  TIP: Dates are always formatted in Oracle in the dd-mmm-yyyy layout (day-month-year).  

mmm is the abbreviated name of the month like MAR for March.  Dates can be entered 

without dashes and with only the last two characters of the year (ddmmmyy) and Oracle will auto-expand 

them. (For example for the date of March 1
st
, 2008 enter 01MAR08). 

 

Pick Lists:  Like LOVs this field’s validation requires selection of an item from the provided 

list.  This list has its values automatically displayed for you.  

 

Text Fields:  Will not always have a LOV Icon displayed when you navigate to them.  In most 

cases if you are on a search/find screen you should be able to use wildcards.    

 

Web Search Forms:  These forms are not case sensitive and you press the GO button to 

initiate the search and the results are listed below the criteria. There are no LOV only search 

fields and pick lists.   Some forms will have you click a link to drill down like the supplier name 
but in this case you must click the update Icon.    

 

Drill 

Down 

Action Button 
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Record & Field Navigation 

 

Switch responsibilities to DC AP Inquiry and select Invoices.  Search for a trading 

partner/supplier that starts with “Atos” 

 

Common Navigation:   Forms can display a single record or contain grids that display 
multiple records.  Navigation commands are listed below.  Try them on the Atos results… 

Change the folder to see a more efficient organization of the columns.  Creating folders is an 

advanced topic. 
 

Menu Shortcut Keys Function 

View->Record->First  [Alt]+v+d+f on Grid Navigates to first selected record 

View->Record->Last [Alt]+v+d+l on Grid Navigates to the last selected record 

 [UP Arrow] on Grid Navigates to previous record 

 [Down Arrow] on Grid Navigates to Next record 

 [Page Up]  on Grid Gives you previous set of records 
based on the size of the grid 

 [Page Up]  on Form Displays the Previous record 

 [Page Down] or [Shift] + 
[F8] on Grid 

Gives you next set of records based on 
the size of the grid 

 [Page Down] Gives you the next record 

 [Tab] Navigates to the next field 

 [Shift]+[Tab] Navigates to the previous field 

 [Enter] Select the default button on the 

Screen Usually has Bold outline. 
 

Use the View->Record->Last menu option to navigate to the last record.  If more than 100 

records are queried, a decision window opens prompting you to either:   (CHOOSE STOP) 

o Continue - Retrieve the next 100 records and 

repeat the decision window unless all records 
have been retrieved.   

o Continue to End - Retrieve all records queried 

and display the last record of the query. 

o Stop - Display the last record of the records 

retrieved.  
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Using Query by Example 
 

When entering an oracle function (Invoices) the related search screen is often automatically 

displayed.  It can also be invoked at any time using the flash light icon.  The search 
functionality should be your first method of searching.  Its strengths are in supporting ranges 

and LOVs.    

 

The alternative search method is called Query by Example.  It can be invoked on forms and on 

grids.  You can use query language to search for harder to find information but there is more 

risk.   
1. Navigate to the screen or grid that you want to query.     

2. Use the menu or short cut to initiate the query-by-form entry 

3. Enter criteria (this will not be remembered) 

4. Execute or cancel  

 
Caution:   Query by example is independent from any previous filtering criteria like previous 

searches.   If you Execute the Query without providing a condition you will attempt to bring 

back all records…  20+ years worth of invoices on this screen… There is no safeguard to stop 

after 100 records.   Your session is lost until it times out and you will have to start a new 

session…  and  using Ctrl+Alt+Delete and task manager to end Oracle it is still running on the 

server and you have impacted the performance of Oracle in general. 
 

Menu Shortcut Keys Function 

View->Query by 

Example-> Enter 

[F11] Sets the data form in Enter Query mode.  
At this point search criteria can be 
entered. 

View->Query by 
Example-> Run 

[Ctrl] + F11  (Use caution) Executes the Query and depending on 
entry results will be return and data entry 
mode is turned on. 

View->Query by 

Example-> Cancel 

[F4] Returns form to data entry mode without 
performing query. 

 [F4] Ends/Cancels current activity.  Can also 
be used to exit forms, etc. 

 [F12] Returns the record count only based on 
entered query.  Count will be displayed on 
the message line. 

 

Attention: In Enter Query mode, all check boxes are initially in a null state. To use a check 

box as a search criterion, you must explicitly check or uncheck it. 

 

Entries are case sensitive.   Most data entered into Oracle is UPPER CASE. 
 

Exercise:  Will be combined 

with the Export function next. 
Operator  Meaning  Example Expression  

=  equals  = 'Janet', = 107  

!=  is not  != 'Bob', != 109  

>  greater than  > 99.1, > '01-JAN-2004'  

>=  at least  >= 55  

<  less than  < 1000.00  

<=  at most  <= 100  

#BETWEEN  between two values  #BETWEEN 1 AND 1000  
#BETWEEN ’01-JAN-2003’ AND ’31-JAN-2003’ 

% Wildcard ATOS%  Same rules as on search functions 
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Exporting Data from Oracle Grids 
 

Whatever data is selected in your search/query by form activity can be exported to Excel.     

 

When the data you want to export is presented  
1. Go to the File menu and select Export.   

2. You may receive a progress bar while Oracle is retrieving data.   

3. Once the data has been retrieved Oracle turns control over to 

Internet Explorer (IE) you web browser.   

4. You will be asked to save or open the data file.  You may 

have to go to the windows tool bar to see this message.  

Usually it will flash at you.   Choose Open to view your 
data and determine your next steps. 

 

  Tip:  If the Windows Internet Explorer window 

does not display you need to check your IE 

settings and make sure Oracle is a trusted site 

and the download prompt property is set.  See 

setups. 

 

  Tip:  Oracle 12i will produce the pop up 

message below for Windows 7 users.    This 

message will often hide behind your other 

windows.   If the IE screen is un-responsive 
minimize your windows until you find this 

message and click Yes. 

 

 

 
  

At this point you can use Excel to modify your data and “Save As” to save in the current 
version of Excel.  

 

Exercise:   

 

1. Using the Search Function, find Credit Memo Invoices (Invoice Type is Credit Memo) for 

Staples our current Office supply vendor for the current month.   
2. Change search criteria to search for Standard Invoices. 

3. Get the count of invoices for the current Staples supplier for the current or previous month 

where the Invoice amount > $50.  

4. Export first 100 records. 

 
Trading partner =  

Invoice Type =  

Invoice Date =  

      Invoice Amount = 



Dallas County, Auditor’s Office 4/11/2018 

 20 

Printing a Form Window (Screen) 
 
Oracle will print the active screen using two methods discussed below.  Use windows methods 
[Alt] + Print Screen and Snipping Tool accessory to create a picture of all or part of your screen 
which can be pasted into a document or saved.   

 

1. Select Print from the File Menu or click on the printer icon on the menu bar. 
 

 

 

2. The print window appears (this may be a little slow occasionally) with your windows 

Default Printer in the name box.  You can change your default printer if desired by 

clicking on the down arrow button. You can also change other printing features like 

orientation, paper type and margins.  Click Print when finished. 
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Submitting Requests 
 

The term Request can represent most anything that can execute outside of the forms and 

screens that you are navigating.   Most used requests are reports that are available for financial 

reporting.   Sometimes pushing a button or completing an activity will initiate a request in 
those cases there will be no need for you to do something special.    

 

However, the majority of the time you must find, define specifications, schedule and determine 

delivery options on requests.  Thankfully, you will only see requests that are proper for the 

navigation path you are at.      

 
To Submit a Request: 

 

Use your favorites or choose a responsibility and navigate either a Request or Run form.  

 

You can also get to the Request form from the 
View menu -> View Request, if you are already 

in a form like Invoices. 

 

 

 

 
 

 

Requests opens the Find Request form (Click Submit a New Request Button) and Run opens 

Submit a New Request pop-up directly. 

 

 

 

On the Submit a New Request Window, 

select either Single Request or Request 

Set and click OK. 
 

Request sets are seldom used and 

should be explained by a peer or 

supervisor before executing one. 

 

 
For most Single Requests you will simply pick the request by name and provide the 

parameters.  Other request options have defaults that work well in most cases.     This is a 

great place to use the help (?) icon to review options if you feel the defaults are not adequate. 
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1. On the Submit Request window enter the name of the report or process or in the Request 

Name field or select from the list of values. 

 
2. Enter all Parameters necessary to run the request.  Parameter screens will be different from 

request to request.   A Parameter is information that limits the report to meaningful 

information.  You have to go to the application module user guide for information about the 

business purpose of specific requests.  Those that start with DC were written for Dallas 
County. 

3. At these times:  Will specify when the request executes.  Using the default, “As Soon as 

Possible” will cause your request to be placed in a Queue with other user requests and will 

be executed in sequence and priority 

order.    
 

Which is why if the request is expected to 

run long then it is recommended to 

change this to Once and pick a time after 

5:00 pm.  So it is less likely to compete 

with other users.  
 

Selecting periodically can let you schedule 

re-occurring requests.  

 

4. Upon Completion (Click Options button to 
change)   

a. Save Output is checked and allows you 

to view. View files are saved for 7 days. 

b. Check the printer in the Print To box.  

Click on Options.   

c. Copies = 0 is to help save paper by 
requiring users to look reports before 

printing.  Oracle printers are also network 

printers with different names.   

Note: Printer default values are determined by the Printer profile setting within your user 

profile (Edit -> Preferences –> Profile).  These can be modified.     Certain reports may have a 
required style or printer that you cannot change. 

1 

2 

3 

4 
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5. Click the Submit button to submit your request. Oracle Applications will assigns a request 

ID to each request submission.  You can use the request ID to query for your request output 
in the Completed Requests window.  

6. You can use the Copy button to “copy” settings from a previous run.  You will have an 

opportunity to adjust parameters and settings before you submit. 

 

 
 

7. Click Refresh Data until the Phase shows Completed.  Click View Output to see the report 

on the screen. 

 
You can also review your Requests at anytime by navigating the “Requests”, using the forms 

View menu and select Requests or [Alt]+v+r using keyboard shortcuts. 

 

View Details:  Lets you see the report setups and time started and ended.  This is useful if you 

submit a report multiple times and want to verify which one you want to use. 

 
View Log:  Lets you see messages created regarding the generation of the report.  This might 

include error messages and warnings. 

 

Cancel Request:   If the request has not completed and you no longer want to run it or you 

realize it has an invalid setup you should select the request and press the Cancel Request 
button. 

 

Exercise: 

 

1. Navigate to the DC GL Inquiry run form and pick the request “Chart of accounts – 

Segment values listing”. 
2. Choose the parameter value “Accounts” 

3. Copy the request and change the parameter to “Projects”  

4. Schedule the request to run in 5 minutes. 

5. Close the forms till you get to the Navigation Menu 

6. Find your requests?  Review your output and review your logs 
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Print a Report Request 

 

If you have submitted a report request but did not send it to a printer, you may print the 
request from the View Output screen by clicking TOOLS on the main menu line, selecting Copy 

File.  The report will open in Internet Explorer and you can format/print or save as a file from 

there. 

 
 

Some reports have very specialized formatting requirements and need to be printed directly 

from Oracle but, you don’t want to run the job again.   Select the successful run under the 

requests window and choose the Tools Menu and select Reprint/Republish.   

 

 
 

 

Change the Copies from 0 to 1, verify or select printer and click apply.  A new request will be 
submitted and the print will be sent to the designated printer. 
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If you need to change the printer click the magnifying glass.  Enter all or part of the printer 

name in the Search by field and click Go.   You must select a printer and then click the Select 

button.    

 
 

 

When done making changes click Apply.  Close the window to move on to your next task…. 
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BI Publisher (XML):  

The Upgrade to R12 has introduced a new reporting technology.  It is BI Publisher and it uses 
a format called XML that allows report designers to pull the contents of a report from Oracle 

and presented as FILE formats instead of Oracle Preview.   Many reports have been redesigned 

to use this technology and more are to come. 

The purpose of this training is to give you some general insight on this new technology. 

How do I know my report is an XML report?  One way to tell is that Oracle in most cases tags 

the report name with XML.  The reports developed at Dallas County using this technology will 
in most cases have EXCEL at the end.     

Exercise:   

1. Navigate to  DC PO INQUIRY  Purchasing Inquiry  Report  Run 
2. Type:  %XML% Tab 

 
 

 

3. Select the Encumbrance Detail 
Report.   

4. Cancel the Parameters box.   
5. Find the Layout section. The other 

way to tell is to look at the Layout 
on the report itself.   All XML 
reports must have a layout. 

6. Click the Options button within 
the Upon Completion Section to 
expand the Layout information. 
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7. Navigate to the Format column and click the LOV button to the right.  This allows you to see the 
different formats.   
 

 
 RTF – will open in Microsoft Word  

 PDF – will open in PDF viewer 

 EXCEL – will open in excel  
 HTML – will open in Internet Explorer 

 FO and XML are not recommended for general use if you see them.  
HINT:  Whatever the report designer wants you to use it will be the default.   

Changing from RTF to PDF is fairly safe.  A lot of reports that default to RTF can 

produce output to excel.  This might be helpful if you are attempting to manipulate 

the data like needing to sort or filter.  Keep in mind how it looks in Excel can be 

quite different than the other formats.  You might see DC versions of these XML 
reports where we enhanced the Excel version to be user friendly. Each report must 

be assessed individually. 

8. Click Cancel and OK to close the LOV and Upon Completion windows. 
9. Navigate to Parameters this should open the Parameters window 
10. Enter Accounts From and to  Fund = 00120-00120, Department = Your department or 1070-

1070, Account= 00000-99999, Year=  0000-0000, Project & Grant = 00000 – 00000, Future = 
0000-0000 

11. Enter Encumbrance Dates From = first of last month,  To = todays date  
12. Click OK  and Submit 
13. Navigate to the Request screen and select your report.  
14. Click View Output, Internet Explorer is going to pop up a 

window for you.  Notice is gives you the file size, 
generated file name and what program it will be opened 
in. 

15. Choose Open (You may or may not want to keep this 
report so open it first before you save it.) It is normal to 
get a Download from site message the larger the file the 
longer this takes. 

16. Find the file.  Usually RTF and PDF files will pop up right in 
front of you.  If not and the download message has gone 
away or is not seen then look for it using the program icon 
on your task bar.  In this example you would be looking for 
Word. 
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17. ON YOUR OWN. Use the Copy Single Request 
functionality and change the RTF Output to EXCEL.  
When you open the file the download message is 
not going away.  EXCEL always creates an extra pop 
–up window that you have to respond to.      This 
popup window may hide from you and you will have to click Excel to find it, especially if Excel is 
already open.  You cannot complete the download until you click “Yes”. 
 
HINT:  Another Quirk about the EXCEL format is that if keep the file outside of Oracle you must 
always save as an Excel Workbook.  It is not a normal excel file in its original state. 
 

18. ON YOUR OWN.  Using the same parameters choose the DC Encumbrance Detail Data (XML) and 
see what a custom excel report looks like.  
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Closing 
Actions  

 

1. To close a form. 
This may contain 

multiple windows 

Select File> Close 

Form or use the 

Close Form Icon 
  

2.  To close a single 

window within a 

form click the x at 

the upper right of 

the screen.   
 

3.  Select File>Exit 

Oracle Applications 

to close Oracle 

forms application or 

the red X at upper 
right hand corner. 

 

[F4] key can be 

used to close forms 

and eventually the 
Oracle Application.  

 

and   

 

4.  To close web based applications there should always be a Logout or Logoff.  DO NOT click 

the upper right hand x since this only closes your browser window nothing else leaving your 
application session open and possibly vunerable.  

 

1 

2 

3 

4 
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Reference 
IT Access Control Policy 

Dallas County has established an IT Access Control Policy.  Pertinent Sections are included 

below.  

 

 

 
 

Be aware of best practices security requirements Dallas County will be adhering to: 

 

 
 

For your reference: 

 

 
 
If you believe your password has been compromised, inform your supervisor immediately.  
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Menu Definitions 

File Menu 

The File menu lets you perform several actions in Oracle Applications: 

New  Opens a new record in the active form.  

Open  Opens the detail screen for the current selection. Typically only used with the Tree item.  

Save  Saves any pending changes in the active form.  

Save and Proceed  Saves any pending changes in the active form and advances to the next record.  

Next Step  Updates the Process workflow in the Navigator by advancing to the next step in the process.  

Place on Navigator  Creates an Icon in the Documents tab of the Navigator which can be used to recall the active 
form and its current record.  

Log on as a Different 

User...  

Exits the application and displays the Oracle Applications Logon window.  

Switch Responsibility...  Closes all active windows and displays the Responsibility window.  

Print...  Prints your current window. An application may override this action to allow printing of one 
or more specific reports instead.  

Close Form  Closes all windows of the current form.  

Exit Oracle Applications  Quits Oracle Applications.  

Edit Menu 

Use the Edit menu to edit your data in Oracle Applications: 

Undo Typing  Returns the field to the value it had when it gained focus.  

Cut  Cuts the current selection to the clipboard.  

Copy  Copies the current selection to the clipboard.  

Paste  Pastes the contents of the clipboard into the current field.  

Duplicate   

Record Above  Copies all values from the prior record to the current record.  

Field Above  Copies the value of the current field from the prior row.  

Clear   

Record  Erases the current record from the window.  

Field  Clears the data from the current field.  

Block  Erases all records from the current block.  

Form  Erases any pending changes from the current form.  

Delete  Deletes the current record from the database.  

Select All  Selects all records (for blocks with multi-select).  

Deselect All  Deselects all selected records except for the current record (for blocks with multi-select).  

Edit Field...  Displays the Editor window for the current field.  

Preferences   

Change Password...  Displays the Change Password dialog box.  

Profiles  Displays the Profiles form.  

View Menu 

The View menu provides you with the following options: 
 

Show Navigator  Displays the Navigator window.  

Zoom  Invokes custom defined zooms.  

Find...  Displays the Find window to retrieve records.  

Find All  Retrieves all records.  
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Query by Example   

Enter  Invokes Enter Query mode to enter search criteria for a query by example.  

Run  Executes the query by example.  

Cancel  Cancels the query by example by exiting from Enter Query mode.  

Show Last Criteria  Recovers the search criteria used in the previous query by example.  

Count Matching 
Records  

Counts the number of records that would be retrieved if you ran the current query by 
example.  

Record   

First  Moves the cursor to the first record.  

Last  Moves the cursor to the last record.  

Translations...  Displays the Translations window.  

Attachments...  Displays the Attachments window.  

Summary/Detail  Switches between the summary and detail views of a combination block.  

Requests  Shows the Request form.  

Folder Menu 

The Folder menu lets you customize the presentation of data in a folder: 

New...  Creates a new folder definition.  

Open...  Opens an existing folder definition.  

Save  Saves changes to the current folder definition.  

Save As...  Saves current folder definition to a new name.  

Delete...  Deletes an existing folder definition.  

Show Field...  Displays a field that is currently hidden.  

Hide Field  Hides the current field.  

Move Right  Moves the current field to the right.  

Move Left  Moves the current field to the left.  

Move Up  Moves the current field up.  

Move Down  Moves the current field down.  

Widen Field  Increases the width of the current field.  

Shrink Field  Decreases the width of the current field.  

Change Prompt...  Changes the prompt for the current field.  

Autosize All...  Adjusts all field widths to completely show their data.  

Sort Data...  Specifies sort order for the first three fields by ascending, descending and no ordering.  

View Query...  Displays the query criteria for the current folder definition.  

Reset Query  Erases the current query criteria.  

Folder Tools  Displays the folder tool palette.  

 

Tools, Reports and Actions Menus 

The Tools menu displayed on the left represents the pull-down options available when the 

Navigator window is active.  

Two additional menus with default labels of Reports and Actions may also be used. These 

menus are not displayed by default.  

Each menu may contain up to fifteen product-specific entries. Examples of product-specific 
entries may include a list of commonly used Inquiry windows in the application, or a commonly 

used window that a user may want to display for a quick reference.  
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Window Menu 

The Window menu displays the names of all open application windows and window placement 
options. 

Cascade  Displays any open windows in a "cascaded" or stair-stepped fashion.  

Tile Horizontally  Displays any open windows in a horizontally "tiled" (non-overlapping) fashion.  

Tile Vertically  Displays any open windows in a vertically "tiled" (non-overlapping) fashion.  

1 (Open Window)  Displays a list of open windows.  

Help Menu 

Use the Help menu to get additional information about Oracle Applications: 

Window Help  Displays help for the current window.  

Oracle Applications 
Library  

Displays a window that lists all available Oracle Applications help text.  

Keyboard Help...  Displays the current key mappings of specific functions and menu options.  

Diagnostics  All of the entries in these menus are used for debugging. You may be asked to use some of these 
functions if you need to contact Oracle Support. Before you can use these functions, your system 
administrator must give you access.  

Display Database 

Error  

Displays the last database error.  

Examine  Displays the underlying Oracle Forms block and item corresponding to a field on the form.  

Test Web Agent  Performs a check of the Web Agent to determine if it is configured properly.  

Trace  Toggles on or off the SQL Trace facility for the current session. SQL Trace provides performance 

information on individual SQL statements.  

Debug  Turns on the Oracle Forms Debugger, provided the form you are currently in was started in 
debug mode.  

Properties  The Properties submenu provides diagnostic information for Items and Folders.  

Item  Displays the values for properties of the current item.  

Folder  Writes diagnostic information about the current folder to a file in the temporary directory.  

Custom Code  The Custom Code submenu is an option group, allowing you to change the mode of the custom 
library.  

Normal  The custom library is used. This is the default.  

Off  Turns the custom library off, disabling Zooms and any other custom code.  

Record History  Displays information about the current record.  

About Oracle 

Applications...  

Displays information about the current application, including version and environment 

information.  
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Basic GUI Terminology 
 

 

Before using Oracle Applications, you should familiarize yourself with the specifics of your GUI 
(Graphical User Interface) environment and how to perform basic tasks, such as using a menu 

or selecting an item.  In doing so, you should encounter and become familiar with the following 

generic terms: 

 

 
Desktop The part of your computer monitor that displays information and your 

work also referred to as your screen. 

 

Window A box around a set of related information items on your desktop. 

 

Menu A list that appears in a bar across the top of a window that consists of 
commands or actions you can perform. 

 

Click Press and release of the mouse button while the mouse pointer is on a 

particular item. 

 

Double-click Rapidly clicking the mouse button twice while the mouse pointer is on a 
particular item. 

 

Drag Click and hold the mouse pointer on the item to move, then move the 

mouse dragging the item to a new position. 

 
Select Highlight the item and initiate the action associated with the item by 

either double-clicking the item or clicking once on the item and pressing 

[Enter].   

 

Scroll Bar A vertical or horizontal bar that appears on a window whose contents are 

not entirely visible.  Hidden information can be viewed through clicking 
on the arrows, dragging on the box in the scroll bar moving it upward or 

downward, or clicking in the bar itself to move to the previous or next 

page. 

 

[AAA] Denotes a key to press or a series of keystrokes. 
 

Note:  The mouse button that we refer to in the terms above is the mouse button that 

you program for selecting text and choosing items, usually the left mouse 

button. 
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Glossary 
 

 

Application – a group of programs that Oracle sells as a set.  This term is synonymous with 
Module.  Examples of applications include Accounts Payable, General Ledger and Purchasing. 

 

Change Request – a request to change the required behavior of a system, usually from a user 

as a result of reviewing current behavior. 

 
Chart of Accounts – a field in Oracle composed of several different pieces of information called 

segments.  These segments include the fund, department, account, and other related 

information that is used in the general ledger to define a transaction or event. 

 

Custom Reports – reports designed to fit the client’s needs as well as to implement 

functionality that is not met by standard Oracle reports. 
 

Customization – programming code added to Oracle in order to implement business 

functionality that is not met with Oracle’s standard functionality. 

 

Database Instance – one set of database management processes and an allocated area in 

memory for managing those processes. 
 

Descriptive Flexfield – a text field that may be added to track an important piece of 

information for which a field does not already exist in the application. 

 

Key Flexfield – a key field in Oracle that contains multiple segments.  For example, the 
account coding is a Key Flexfield that could contain individual segments such as fund, 

organization, program and line item. 

 

Modification – a change in the configuration of Oracle, does not require code changes. 

 

Module – a group of programs that Oracle sells as a set.  This term is synonymous with 
Application.  Examples include Accounts Payable, General Ledger and Purchasing. 

 

Oracle Responsibilities Matrix – a responsibility is a level of authority in Oracle Applications 

that lets you access only those functions and data appropriate to fulfill your role in the 

organization. 
 

Production – the systems environment that supports live business operations in Oracle. 

 

Patch – an update to improve the functionality of the application software. 

 

Query – a request for Oracle Applications to return only those records that match the user 
defined criteria.  Users can perform queries to retrieve records from most screens in Oracle 

Applications, including those used for data entry. 

 

Quickpick – a list of valid entries for a particular field.  Users can view the list by clicking on 

the List of Values (LOV) Icon on the Toolbar or by typing the first known characters of the 
subject to display a condensed list of only those values containing the characters entered. 

 

 


